my patch was wrong at dlls/kernel32/computernames.c
Aug. 29, 2013
2:31 p.m.
From if ( isalnumW ( wc ) ) return wc; for ( i = 0; i < 17; i++ ) To if ( isalnumW ( wc ) ) return wc; for ( i = 0; i < 16; i++ ) and the original version was wrong,too. It counts the NULL of the end.
Aug. 29, 2013
2:35 p.m.
On Thu, Aug 29, 2013 at 11:31:06PM +0900, matyapiro31 wrote:
From if ( isalnumW ( wc ) ) return wc; for ( i = 0; i < 17; i++ ) To if ( isalnumW ( wc ) ) return wc; for ( i = 0; i < 16; i++ ) and the original version was wrong,too. It counts the NULL of the end.
Thats why you should use sizeof() or strlen() ... and not hardcoded magic values. CIao, Marcus
4770
Age (days ago)
4770
Last active (days ago)
1 comments
2 participants
participants (2)
-
Marcus Meissner -
matyapiro31