--
v2: ntdll/tests: Add more tests for \Device\NamedPipe and \Device\NamedPipe\.
ntdll/tests: Add tests for exotic pipe names.
kernel32/tests: Add test for pipe name with a trailing backslash.
https://gitlab.winehq.org/wine/wine/-/merge_requests/1070
Hello, this is the first part of a patch series to support:
* Complex broadcasts.
* Complex implicit casts between component-wise equal types.
* Complex explicit casts between component-wise compatible types.
This first part of the series includes mostly tests.
Following patches in: https://gitlab.winehq.org/fcasas/vkd3d/-/commits/complex_broadcasts_2/
This supersedes !16 .
--
v3: tests: Test explicit casts between types that are component-wise
tests: Test implicit casts between types that are equal component-wise.
vkd3d-shader/hlsl: Always go through implicit conversion in assignments.
tests: Test for invalid complex broadcasts.
tests: Rename structs for readability in broadcast test.
tests: Set ULPs to 2 in normalize() test.
https://gitlab.winehq.org/wine/vkd3d/-/merge_requests/29
The default for MinGW is always ms_printf rather than gnu_printf, but if we are
using ucrtbase or ANSI stdio, we want gnu_printf.
--
v2: include: Use __MINGW_PRINTF_FORMAT when compiling with MinGW.
https://gitlab.winehq.org/wine/vkd3d/-/merge_requests/18
The Windows versions of [Read|Write]ConsoleOutput[Attribute|Character]
appear to assign an uninitialized internal DWORD to the given pointer
address before returning.
As the functions fail (intentionally) in these tests, the value of the
DWORD is never set, so the tests end up comparing the expected value of
zero with random values.
This value of this test is very limited and is best removed.
Fixes https://bugs.winehq.org/show_bug.cgi?id=53686
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/1077
Rémi Bernon (@rbernon) commented about dlls/ntdll/unix/signal_x86_64.c:
> "movq %gs:0x30,%rcx\n\t"
> "movq 0x328(%rcx),%rcx\n\t" /* amd64_thread_data()->syscall_frame */
> "popq 0x70(%rcx)\n\t" /* frame->rip */
> + __ASM_CFI(".cfi_adjust_cfa_offset -8\n\t")
> + // $rip = frame->rip // (*(0x70($rcx)))
I understand the point but I don't think we need to keep these comments. We also don't use C++-style comments.
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/1065#note_10939