On Thu Sep 1 16:28:33 2022 +0000, eric pouech wrote:
for what it's worth, I don't like the idea of having three redundant global variables (winetest_platform, is_wine, is_windows)
- it lacks IMO for the two is_??? a winetest_ prefix (to limit potential
names conflict)
- winetest_platform should no longer be a global variable (kept local to
main()) (but ~50 changes to be done)
The original scheme assumes there can be other platforms besides wine and windows: after all we explicitly check for wine and windows, not wine and !wine. So that justifies preserving access to winetest_platform.
But I admit it's hard to figure out what any other platform would be: some other windows reimplementation? It clearly cannot be Wine's underlying platform (macOS, Linux, BSD) even if that could be useful sometimes. Maybe that would justify changing the whole scheme to a simple boolean.
The issue with a winetest_is_ prefix is that makes the variable names really long and annoying. So I think it's fine to let them join the other short names like ok(), skip(), etc.