Giovanni Mascellani (@giomasce) commented about libs/vkd3d-shader/vkd3d_shader_private.h:
VKD3D_SIV_LINE_DENSITY_TESS_FACTOR = 22,
};
+struct sm6_signature_element +{
- const char *semantic_name;
- unsigned int semantic_index;
- unsigned int stream_index;
- enum vkd3d_shader_sysval_semantic sysval_semantic;
- enum vkd3d_shader_component_type component_type;
- unsigned int register_index;
- unsigned int register_count;
- unsigned int mask;
- unsigned int used_mask;
- enum vkd3d_shader_minimum_precision min_precision;
+};
Is it really sensible to call this `sm6_signature_element`? AFAIU it is not specific for SM6, it is used for all shader models. Maybe `internal_signature_element` would be a more neutral name?
Relatedly, why isn't the new field exposed to the public API? Just because we don't want to go through the hassle of updating the public API, or is it genuinely uninteresting for our clients?