On Tue Sep 27 10:57:14 2022 +0000, Piotr Caban wrote:
Is there a reason for not using RtlWakeAddressSingle here? How about calling RtlWakeAddressAll only if chore->task_collection->finished == chore->task_collection->count?
I used `RtlWakeAddressAll` because I don't know that there will only ever be a single waiter. Maybe two threads call `_StructuredTaskCollection::_RunAndWait`, or we add a wait in the worker threads at some point. Is `RtlWakeAddressAll` less performant than `RtlWakeAddressSingle`?