Bernhard Kölbl (@besentv) commented about dlls/windows.media/captions.c:
+#include "private.h"
+#include "wine/debug.h"
+WINE_DEFAULT_DEBUG_CHANNEL(captions);
+const char *debugstr_hstring( HSTRING hstr ) +{
- const WCHAR *str;
- UINT32 len;
- if (hstr && !((ULONG_PTR)hstr >> 16)) return "(invalid)";
- str = WindowsGetStringRawBuffer( hstr, &len );
- return wine_dbgstr_wn( str, len );
+}
+struct captions
I'd also be in favor of renaming this to sth like `captions_statics` since, from a UWP API pov, you're implementing a static class with static interfaces, that do not rely on some sort of "COM-instance".