Oof, I wrote these too, but you beat me to it :x
I'd remove the "fold" from the function names, since they're not folding anything by themselves. (Also, "float_to_uint" instead of "float_to_unsigned"?)
This doesn't deal with double comparisons. I think you can reuse the same functions by changing their arguments to doubles.
The explicit casts seem superfluous.