Make both method calls;
1. Consistently written with parameter names as per spec. 2. Fix parameter validation to be consistent with spec. 3. Fix szNameBuf parameter semantics as per spec. 4. Fix szNameBuf casing str search as per spec. 5. Factor out common code into TLB_ helpers vastly improves readability.
-- v7: dlls/oleaut32: Fix nonsensical memory access in ITypeLib2_Constructor_SLTG() dlls/oleaut32: Avoid ptr arithmetic in MSFT_DoVars() dlls/oleaut32: Avoid ptr arithmetic in ITypeLib2_Constructor_SLTG() dlls/oleaut32: Shink down ITypeLibComp_fnBind() verbosity some dlls/oleaut32: ptr_size should be a ULONG dlls/oleaut32: Scope indexer to loops in fn[Is|Find]Name() dlls/oleaut32: Factor out TLB_get_funcparams_by_name() dlls/oleaut32: Factor out TLB_get_funcdesc_by_name() dlls/oleaut32: Validate args of ITypeLib2_fnIsName() dlls/oleaut32: fn(Is|Find)Name should set szNameBuf with correct case dlls/oleaut32: Use consistent param identifiers in fnFindName dlls/oleaut32: Mostly mirror fnFindName impl in typelib.c dlls/oleaut32: Use common and correct identifiers in typelib.c dlls/oleaut32: Consistently use lstrcmpiW() while looking for names