Jinoh Kang (@iamahuman) commented about dlls/ntdll/unix/signal_x86_64.c:
}
+/***********************************************************************
check_invalid_gs
- Check for fault caused by invalid %gs value (some copy protection schemes mess with it).
- */
+static inline BOOL check_invalid_gs( ucontext_t *sigcontext, CONTEXT *context ) +{
- const BYTE *instr = (const BYTE *)context->Rip;
- TEB *teb = get_current_teb();
- WORD system_gs = ds64_sel;
- ULONG_PTR cur_gs = 0;
In light of the GS/GSBASE confusion, I suggest you to rename this to `cur_gsbase`.
```suggestion:-0+0 ULONG_PTR cur_gsbase = 0; ```
(plus subsequent variable accesses)