On Fri Feb 10 12:17:03 2023 +0000, Conor McCarthy wrote:
The device mutex is for protecting the cache so it should probably be renamed at some point. You're right about creating a separate one for blocked queues.
Actually, while I was creating `blocked_queues_mutex` I also wondered if the current `mutex` can be further split. In `state.c` it seems that it is used to protect both `cache->render_passes` and `graphics->compiled_pipelines`, and it's not clear to me whether these two uses are independent or not. If they are, the mutex can be further split, and in principle I guess that it's a good idea, when possible, to keep locking as granular as possible. But since I don't know much that code, I didn't venture doing anything.