Paul Gofman (@gofman) commented about dlls/ntdll/tests/sync.c:
- ok( p->apc_count > 0, "no APCs were delivered\n" );
- ok( p->apc_count <= NUM_APCS, "got %ld APCs, expected at most %d\n",
p->apc_count, NUM_APCS );
- return 0;
+}
+static void test_delayexecution(void) +{
- static const struct test
- {
LONGLONG timeout;
BOOLEAN alertable;
enum { API_NTDELAY, API_SLEEPEX, API_SLEEP } api;
- }
Is coding function really necessary in the table? Probably less code and more readable to just call all the three inside the test loop body (yes, for Sleep() there will be some repeated tests in this case, so what)? Then maybe some of the branched checks there can be coalesced.