Two comments to the first patch:
- We already have Init / InitAudio tests in test_InitAudio() from tests/performance.c. Having them in two different files is unexpected. - The comments in the test confused me and I had to read the code to understand them * First part of the test just retests that after a manually initialized dmusic the performance Init() still succeeds (fixed some app crashes there before). The addition to test_InitAudio() is that a port is created and activated. * The other main take away is that the performance Init() or InitAudio() succeeds again after a CloseDown(). But the comment makes it sound as Init() would succeed if we'd just use a different dsound.
For "dmime: Initialize performance in Init rather than InitAudio.": I've had to read my old commits there as I had centralized that in InitAudio(). Duplicated code and InitAudio() calling Init() the wrong way. Anyway main motivation to do it this way was the usual older method calls new method approach, e.g. Foo() ==> FooEx().\ But later I've learned that that switches the performance to a different operation mode.
Anyway, I'm not opposed to the patch, only concern I had in the back of my mind is if Init() and InitAudio() aren't too different for one to call the other.