Giovanni Mascellani (@giomasce) commented about libs/vkd3d-shader/dxil.c:
break;
case TYPE_CODE_INTEGER:
{
uint64_t width;
if (!record->operand_count)
{
WARN("Missing integer width for type %u.\n", type_index);
return VKD3D_ERROR_INVALID_SHADER;
}
type->class = TYPE_CLASS_INTEGER;
width = record->operands[0];
if (width > 64 || (width > 1 && width < 8) || vkd3d_popcount(width) != 1)
It's not a big deal, but isn't it more readable to just list the five accepted values?