Zebediah Figura (@zfigura) commented about libs/vkd3d-shader/hlsl.h:
struct hlsl_ir_function {
- /* Item entry in hlsl_ctx.functions */ struct rb_entry entry;
- const char *name;
- /* Container for hlsl_ir_function-decl.entry, containing all the function definitions. Which
struct rb_tree overloads;* may be more than one (overloading). */
Besides not really being grammatical, this seems a bit redundant, given that the field is named "overloads". Also, hlsl_ir_function_decl in this comment has a dash in place of an underscore. I'd advocate something like "Tree of function overloads, stored as hlsl_ir_function_decl structures."