Matteo Bruni (@Mystral) commented about dlls/d3dx9_36/d3dx9_private.h:
return is_top_level_param_dirty(param->top_level_param, update_version);
}
-struct d3dx_parameter *get_parameter_by_name(struct d3dx_effect *effect, +struct d3dx_parameters_store +{
- struct wine_rb_tree tree;
- struct d3dx_top_level_parameter *parameters;
- unsigned int count;
- char *full_name_tmp;
- unsigned int full_name_tmp_size;
+};
Just a clarification really: the tree is only used to make get_parameter_by_name() fast. It would be nice to give it a better name but I can't come up with anything.