+dist_noinst_SCRIPTS = tests/test-driver.sh +dist_check_SCRIPTS = tests/test-driver.sh
Do you need both of those? Wouldn't dist_check_SCRIPTS be sufficient on its own?
I was wondering because I found this automake manual entry ambiguous: ``` Scripts that need not be installed can be listed in noinst_SCRIPTS, and among them, those which are needed only by ‘make check’ should go in check_SCRIPTS. - Section 9.1 Executable Scripts. ```
But I see now that it also says: ``` The special prefix ‘check_’ indicates that the objects in question should not be built until the ‘make check’ command is run. Those objects are not installed either. - Section 3.3 The Uniform Naming Scheme ```
I also ran `make install DESTDIR=...` after removing `dist_noinst_SCRIPTS` and didn't see the script in the DESTDIR. So it is most probably not necessary.
+SHADER_TEST_LOG_DRIVER = tests/test-driver.sh +AM_COND_IF([BUILD_TESTS], + [AC_CONFIG_LINKS([tests/test-driver.sh:tests/test-driver.sh])])
We probably want that to be "SHADER_TEST_LOG_DRIVER = $(srcdir)/tests/test-driver.sh" for out-of-tree builds.
+AM_COND_IF([BUILD_TESTS], + [AC_CONFIG_LINKS([tests/test-driver.sh:tests/test-driver.sh])])
...and then we can just drop this.
Thanks! It looks far better than creating a symbolic link.