Zebediah Figura (@zfigura) commented about dlls/msado15/tests/msado15.c:
- ok( hr == S_OK, "got %08lx\n", hr );
- SysFreeString( str );
- for (i=0; i < ARRAY_SIZE(filters); i++)
- {
BSTR crit = SysAllocString( filters[i].filter );
hr = _Recordset_MoveFirst( recordset );
ok( hr == S_OK, "got %08lx\n", hr );
V_VT( &index ) = VT_I4;
V_I4( &index) = 0;
hr = _Recordset_Find( recordset, crit, 0, adSearchForward, index );
ok( hr == filters[i].expected, "%d got %08lx expected %08lx\n", i, hr, filters[i].expected );
SysFreeString( crit );
I originally wrote "should we check the returned index here too?" and then realized that "index" isn't the returned index, it's the index at which to start searching. Perhaps it could be renamed to something like "start_index" to communicate that more clearly...