eric pouech (@epo) commented about programs/cmd/directory.c:
- FIXME: Assumes 24-line display for the /P qualifier.
*/
-static DIRECTORY_STACK *WCMD_list_directory (DIRECTORY_STACK *inputparms, int level) { +static DIRECTORY_STACK *WCMD_list_directory (DIRECTORY_STACK *inputparms, int level, RETURN_CODE *return_code) {
nitpick: IMO it's more readable to return a RETURN_CODE, and pass a DIRECTORY_STACK** to update the pointer (you likely did it this way to minimize change, but let's take the opportunity of a change to sanitize a bit the current spaghetti code)