Zebediah Figura (@zfigura) commented about dlls/kernelbase/file.c:
}
-/***********************************************************************
- CopyFileExW (kernelbase.@)
+/******************************************************************************
- CopyFile2_impl
- uses the SetLastError style of error handling since CopyFileEx returns
- WIN32 error codes and HRESULT to WIN32 conversion is easier
*/
- than the other way around.
-BOOL WINAPI CopyFileExW( const WCHAR *source, const WCHAR *dest, LPPROGRESS_ROUTINE progress,
void *param, BOOL *cancel_ptr, DWORD flags )
-{ +static BOOL CopyFile2_impl( const WCHAR *source, const WCHAR *dest, COPYFILE2_EXTENDED_PARAMETERS *params ) {
This doesn't match the usual naming scheme for helpers. I'd just call it copy_file().
The brace placement doesn't match what's used elsewhere in this file.