Zebediah Figura (@zfigura) commented about dlls/ws2_32/tests/sock.c:
+{
- int sockfd;
- SOCKADDR_UN addr;
+};
+static DWORD WINAPI test_afunix_client_connect_thread(void *param) +{
- struct afunix_thread_param *in = param;
- ok(!connect(in->sockfd, (SOCKADDR *)&in->addr, sizeof(in->addr)), "Could not connect to Unix socket: %lu\n",
GetLastError());
- return 0;
+}
+static void test_afunix(void) +{
- SOCKET server, client, conn;
This naming is understandable, but a bit confusing, since much of the rest of the file uses the convention "listener, server, client", where "server" is returned from accept(). For the sake of clarity to someone reading the test I'd request that it be changed to match that.