Zebediah Figura (@zfigura) commented about dlls/msado15/recordset.c:
return S_OK;
}
+static void clear_recordset_filter(struct recordset *recordset) +{
- struct column_filter *filters, *filters2;
- LIST_FOR_EACH_ENTRY_SAFE(filters, filters2, &recordset->filters, struct column_filter, entry)
- {
list_remove(&filters->entry);
VariantClear(&filters->value);
free(filters);
- }
Shouldn't this be "filter" in the singular? It's confusing and makes the function look like it's doing the wrong thing otherwise...