On Fri Jul 29 18:37:06 2022 +0000, Angelo Haller wrote:
changed this line in [version 4 of the diff](/wine/wine/-/merge_requests/550/diffs?diff_id=6469&start_sha=6d7ce5888531e24c0376cf77c754c38404607d3b#0251bfdc5c488ffd767c45cd3a965188becc33f7_3735_3681)
I changed it to TRUE/FALSE.
Otherwise I defined the variable in function scope, happy to change that if needed. Just found it easier, as this way the definition is a little closer to the place where it is used.
You can also add a current key state to avoid calling hold_key() if a key is already being held.
I thought about that, but ended up deciding against doing so. It added a lot of code complexity for no observable benefit (at least to me). Lots of `if (sequence[i].hold_shift && !shift_held)`, `if (!sequence[i].hold_shift && shift_held)` and extra clean up code after the loop to not break subsequent tests.
I also removed most of the comments, as the description is now part of the kbd_select_sequence.