Modifiers are otherwise for actual modifier keywords. I can't say this is wrong but it's definitely weird. Less weird would be to use a dedicated HLSL_TYPE_* or a UAV-specific flag.
Something like ```c if (uav && resource->data_type->e.uav.rasteriser_ordered) instr.opcode |= VKD3DSUF_RASTERISER_ORDERED_VIEW << VKD3D_SM5_UAV_FLAGS_SHIFT; ``` you mean?