On Thu Oct 17 03:05:17 2024 +0000, Elizabeth Figura wrote:
This function is confusing. It's called "loop_run", "loop_once", and "loop", but its use here implies it's not supposed to do any looping, but rather retrieve an event. Why not call it "get_event"? And "winebluetooth_event_loop_result" can just be "winebluetooth_event".
Renamed the function and struct to `winebluetooth_get_event` and `winebluetooth_event` respectively. However, I've still left the actual function in `dbus.c` as `bluez_dbus_loop`, since it does loop until the DBus event loop produces an event of interest to us.