On Fri Nov 10 16:37:58 2023 +0000, Alexandre Julliard wrote:
The wayland surface coordinates are inherently expressed as real
numbers, so `wayland_surface_coords_from_wine` would normally be `int -> double`. I am fine dropping the `rounded` if you prefer, and if we need the `int -> double` variant I can do a `wayland_surface_coords_from_wine_unrounded` or similar. Does that sound OK? Sure.
For `wayland_surface` functions, the Wayland surface-local system is
the natural system to express coordinates in, hence I chose `x` (i.e., less context since it's implied by the object we are working with) and `wine_x`. I am fine inverting the names along the lines of `wayland_x` and `x` if you feel strongly about this. It's better to avoid naming things `wine` or `wayland`, because in the driver basically everything is both Wine and Wayland stuff. I'd suggest terms like logical/physical (cf. `NtUserPerMonitorDPIPhysicalToLogicalPoint`), or surface/window.
Ack. Changed functions to `wayland_surface_coords_(to|from)_window` with arguments `window_*` and `surface_*`.