Why is one _rounded and not the other one?
The wayland surface coordinates are inherently expressed as real numbers, so `wayland_surface_coords_from_wine` would normally be `int -> double`. I am fine dropping the `rounded` if you prefer, and if we need the `int -> double` variant I can do a `wayland_surface_coords_from_wine_unrounded` or similar. Does that sound OK?
Also could we please avoid naming things wine_something? winewayland.drv is also part of Wine, it's not some external thing that the driver has to deal with.
For `wayland_surface` functions, the Wayland surface-local system is the natural system to express coordinates in, hence I chose `x` (i.e., less context since it's implied by the object we are working with) and `wine_x`. I am fine inverting the names along the lines of `wayland_x` and `x` if you feel strongly about this.