Zebediah Figura (@zfigura) commented about libs/vkd3d-shader/hlsl_codegen.c:
struct copy_propagation_value {
- enum copy_propagation_value_state state;
- unsigned int timestamp;
- bool statically_written; struct hlsl_ir_node *node; unsigned int component;
};
+struct copy_propagation_trace +{
- struct copy_propagation_value *records;
- size_t record_count, record_capacity;
+};
This is a single component, right? For clarity can we rename it to something that has "component" in it?