Okay, makes sense, what about returning a enum wg_transform_status with a set of flags then?
Not to overly bikeshed, but I'd rather use bool variables, or if we must use a bitfield, let's not define it with an enum; that's not what enums are for.
Or simply leave the code as is but assume that needs_input is never NULL.