Jacek Caban (@jacek) commented about dlls/mshtml/htmldoc.c:
return CONTAINING_RECORD(iface, HTMLDocument, IDispatchEx_iface);
}
-static HRESULT dispid_from_elem_name(HTMLDocumentNode *This, BSTR name, DISPID *dispid) +static HRESULT dispid_from_elem_name(HTMLDocumentNode *This, const WCHAR *name, DISPID *dispid, BOOL enum_name)
I think it would be better to move !enum_name handling out of this function instead of adding an extra argument here. If you move that to a separated function, it could also be used in HTMLDocumentNode_next_dispid instead of duplicating it.