Rémi Bernon (@rbernon) commented about dlls/dmime/midi.c:
- else
- {
if ((status & 0xf0) != 0xc0 && (status & 0xf0) != 0xd0)
if ((hr = stream_read_at_most(stream, &byte, 1, bytes_left)) != S_OK) return hr;
FIXME("MIDI event status %#02x, time +%lu, not supported\n", status, delta_time);
- }
- return S_OK;
+}
HRESULT midi_parser_next_track(struct midi_parser *parser, IDirectMusicTrack **out_track, MUSIC_TIME *out_length) {
- TRACE("(%p, %p, %p): stub\n", parser, out_track, out_length);
- WORD i = 0;
- TRACE("(%p, %p): stub\n", parser, out_length);
- while (TRUE)
```suggestion:-1+0
TRACE("(%p, %p): stub\n", parser, out_length);
for (;;) ```
I believe wine more often uses `for (;;)` for unbounded loops. A bit of spacing around traces would make it more readable too.
Or maybe alternatively it could be:
```suggestion:-1+0
TRACE("(%p, %p): stub\n", parser, out_length);
for (i = 0;; i++) ```
Saving you the increment in the end.