This seems reasonable to me, but I think it would be cleaner to put it after the `switch` block, like:
``` switch (d_type) { ... } /* no special d_type for parallel ports */
#if defined(__APPLE__) /* /dev/null on has been 3, 2 since the start of OSX */ if (d_type == D_DISK && major(st.st_rdev) == 3 && minor(st.st_rdev) == 2) info->DeviceType = FILE_DEVICE_NULL; #endif ```