On Tue Oct 31 15:31:45 2023 +0000, Rémi Bernon wrote:
I used "decl" here as a name because the expression member is a "decl_spec", but it could have been "type" if that matters. Do you mean that an expression cannot be a "type" expression? Why not, as we can very well have `sizeof(expression)` as well as `sizeof(type)`?
Can it be `sizeof(expression)` in IDLs? Quick check with midl doesn't confirm that and our parser expects a type as well. It's allowed in C, but I think its argument is specified as "type or expression". You also can't use `(expression)expression` for a cast just like you can't do `0 + (type)`.