Why are we translating to a different flags enum? Why not pass this flag enum directly?
To keep it consistent. The `WINEBLUETOOTH_RADIO_PROPERTY` constants get used to inform the driver about property changes (`bluez_filter`, `bluetooth_radio_set_properties`), and to check if the properties for the adapter are known in `IOCTL_BTH_GET_LOCAL_INFO`. So, I thought it'd be better if the unix/dbus code only used the `WINEBLUETOOTH_*` constants.
It's bikeshedding, and I won't push very hard on this issue, but I can't say I see any reason to keep the unix side only using one set of constants. If anything it seems more obscure to me; it's clearer to do as little conversion as possible.
Why convert to an intermediate set of flags instead of just passing the params directly to the Unix side?
Yeah, I'm also not sure if the bitfields would work across unixlib boundaries. I can just use `BOOL`s for LE and BR/EDR in the next MR if that's better.
I'd recommend it. I don't know that the bitfields *won't* work, they very well may, but they're not really necessary either.