That's both old and nonstandard, and while I'm not going to argue too hard against fixing these warnings, it doesn't seem the best use of time. I have to wonder how many other such warnings exist across the codebase with those options...
Quite a few, not too many though.
Anyway, suppressing -Wmaybe-uninitialized by initializing the variable to a dummy value is bad for clarity, and in my experience almost never the right solution. In this case I'd rather replace the for + if pattern (which I pretty much universally dislike) with a helper function.
I strongly agree, I honestly didn't like this "solution" anyway. !2863 solved the warning the right way.