So I don't want to block this forever, but I'm going to bikeshed validate_method_call(), sorry :-(
Instead of making it a separate table, what I'd suggest is to merge it in with the existing object_methods[] array. This of course means transposing the table.
The comment at the top would be a lot nicer if it was aligned with the columns.
The 'x' entries are there because generic/comparison textures are filtered out early. That's okay I guess but I'm not sure it's worth adding a separate entry for them.
There are only a couple of 'f' entries, and I would just make them an open-coded hlsl_fixme() rather than adding a whole infrastructure for them.
At that point the table should probably just be 0 and 1 instead of individual chars.