-static enum vkd3d_result vsir_block_list_add(struct vsir_block_list *list, struct vsir_block *block) +static enum vkd3d_result vsir_block_list_add_unchecked(struct vsir_block_list *list, struct vsir_block *block)
Does that mean a caller doesn't need to do checks when calling vsir_block_list_add_unchecked()? :) I can certainly see the logic behind calling this _unchecked, but it seems a bit ambiguous.
Note that in case of e.g. d3d12_command_queue_submit_locked(), the _locked suffix means the caller locks; if we were to be consistent with that naming convention, we'd call this vsir_block_list_add_checked().