On Tue Nov 29 00:01:43 2022 +0000, Zebediah Figura wrote:
Honestly, "rename the field to 'storage_flags'" wouldn't be a bad idea. Clearly, if nothing else, these documentation patches are pointing out a lot of things that we could do better in terms of code naming and organization. Which is probably not unexpected :-)
Okay.
By the way I didn't thought that the separation between type modifiers and storage modifiers was that clear. In particular because `HLSL_STORAGE_VOLATILE` is in the `HLSL_TYPE_MODIFIERS_MASK`.
```c #define HLSL_TYPE_MODIFIERS_MASK (HLSL_MODIFIER_PRECISE | HLSL_STORAGE_VOLATILE | \ HLSL_MODIFIER_CONST | HLSL_MODIFIER_ROW_MAJOR | \ HLSL_MODIFIER_COLUMN_MAJOR) ``` Is this a mistake?