Esme Povirk (@madewokherd) commented about dlls/shell32/shlfileop.c:
CloseHandle(file);
else
ret = GetLastError();
- }
- return ret;
+} +static inline struct file_operations *impl_from_IFileOperation(IFileOperation *iface) +{
- return CONTAINING_RECORD(iface, struct file_operations, IFileOperation_iface);
}
static HRESULT WINAPI file_operation_QueryInterface(IFileOperation *iface, REFIID riid, void **out) {
- struct file_operation *operation = impl_from_IFileOperation(iface);
- struct file_operations *operation = impl_from_IFileOperation(iface);
If this struct must be renamed, then it should be in a separate patch.