Giovanni Mascellani (@giomasce) commented about include/vkd3d_shader.h:
+struct vkd3d_shader_dxbc_section_desc +{
- /** The section tag. */
- uint32_t tag;
- /** The contents of the section. */
- struct vkd3d_shader_code data;
+};
+/**
- A description of a DXBC blob, as returned by vkd3d_shader_parse_dxbc().
- \since 1.7
- */
+struct vkd3d_shader_dxbc_desc +{
- /** The DXBC tag. This should always be "DXBC". */
Should we probably make `VKD3D_MAKE_TAG()` public too? And possibly `TAG_DXBC` too, after renaming? Some users might find not completely obvious how to assign the value `"DXBC"` to a `uint32_t` variable. And while a user trying `desc.tag = "DXBC";` will probably find other problems in their way to a working program, it wouldn't be unpolite to give them some more useful tool.