On Sat Aug 26 12:11:19 2023 +0000, **** wrote:
Dmitry Timoshkov replied on the mailing list:
llde <wine@gitlab.winehq.org> wrote: > From: llde <lorenzofersteam@live.it> Please use your full name when submitting patches. > diff --git a/dlls/secur32/lsa.c b/dlls/secur32/lsa.c > index a9ca8b60283..0f9b8dceb39 100644 > --- a/dlls/secur32/lsa.c > +++ b/dlls/secur32/lsa.c > @@ -967,11 +967,10 @@ void load_auth_packages(void) > if (err != ERROR_SUCCESS) > continue; > > - if (!load_package(name, &package, i + 1)) > + if (!load_package(name, &package, ++i)) > continue; > > add_package(&package); > - i++; > } Thanks for spotting this. Although I'd personally prefer it to look like if (load_package(name, &package, i + 1)) add_package(&package); -- Dmitry.
I do prefer this style, with the affirmative if, too. See if the new version it's of your liking @dmitry