Giovanni Mascellani (@giomasce) commented about libs/vkd3d-shader/tpf.c:
if (!register_type_info) { FIXME("Unhandled register type %#x.\n", register_type);
param->type = VKD3DSPR_TEMP;
} else {vsir_register_type = VKD3DSPR_TEMP;
param->type = register_type_info->vkd3d_type;
}vsir_register_type = register_type_info->vkd3d_type;
- vsir_register_init(param, vsir_register_type, data_type, 0);
It's mostly a matter of taste, but I find it easier to read the code if you immediately parse the index count and pass it appropriately to `vsir_register_init()`.