Zebediah Figura (@zfigura) commented about libs/vkd3d-shader/hlsl_codegen.c:
}
static void prepend_input_copy(struct hlsl_ctx *ctx, struct list *instrs, struct hlsl_ir_load *lhs,
unsigned int modifiers, const struct hlsl_semantic *semantic)
unsigned int modifiers, const struct hlsl_semantic *semantic, uint32_t *semantic_index)
I don't like that this is an in-out parameter; the code feels distinctly less readable, and I can't easily tell why this even does the right thing for nested arrays. Can we just make this an input parameter and increment it manually when processing arrays?