Giovanni Mascellani (@giomasce) commented about libs/vkd3d-shader/ir.c:
- else
- {
src[0] = *source;
materialize_ssas_to_temps_process_src_param(program, &src[0]);
- }
- for (i = 0; i < count; ++i)
vkd3d_free(block_info[i].incomings);
- return true;
- vkd3d_free(block_info);
}
-static enum vkd3d_result vsir_program_materialise_ssas_to_temps(struct vsir_program *program) +static enum vkd3d_result vsir_program_materialize_phis_to_temps(struct vsir_program *program) {
- struct materialize_ssas_to_temps_block_info *info, *block_info = NULL;
This should probably be renamed now. Also, please keep the `materialize_ssas_to_temps` stuff contiguous, moving the new `materialize_phis_to_temps` above all of it.