Rémi Bernon (@rbernon) commented about dlls/dmime/dmime_private.h:
extern HRESULT create_dmtempotrack(REFIID riid, void **ret_iface); extern HRESULT create_dmtimesigtrack(REFIID riid, void **ret_iface); extern HRESULT create_dmwavetrack(REFIID riid, void **ret_iface); +extern HRESULT create_midiseqtrack(REFIID riid, void **ppobj, DWORD division);
+MUSIC_TIME get_midiseqtrack_length(IDirectMusicTrack8 *iface);
Fwiw the `create_*` functions are mostly historically named. I don't mind if we keep them with these ugly names (until a cleanup commit to change them all) but I'd prefer that new codes and new helpers to be more readable.
Something like `midi_sequence_track_get_length` as the class is named `midi_sequence_track` would be better IMO.