Personally I find the style of `debug_hlsl_expr_op()` nicer: ```c static const char *const op_names[] = { [HLSL_OP0_VOID] = "void",
[HLSL_OP1_ABS] = "abs", [HLSL_OP1_BIT_NOT] = "~", [HLSL_OP1_CAST] = "cast", [HLSL_OP1_COS] = "cos", ... ```
Not a big deal, anyway, and it's already inconsistent in the current code base.