Jinoh Kang (@iamahuman) commented about dlls/ntdll/heap.c:
return STATUS_SUCCESS;
}
+/* Low Fragmentation Heap frontend */
+/* header for every LFH block group */ +struct DECLSPEC_ALIGN(BLOCK_ALIGN) group +{
- SLIST_ENTRY entry;
- /* one bit for each free block and the highest bit for GROUP_FLAG_FREE */
- LONG free_bits;
- /* affinity of the thread which last allocated from this group */
- LONG affinity;
- /* first block of a group, required for alignment */
- struct block blocks;
Since the comment calls it the first block, maybe it's a good idea to make it clear in the name as well.
```suggestion:-0+0 struct block first_block; ```
I think `blocks` would be more appropriate if it was declared as a flexible array member (or at least as a 1-sized array) and the block itself was fixed-size.