https://bugs.winehq.org/show_bug.cgi?id=43707
Bug ID: 43707 Summary: [GdiPlus] HatchStyle is incorrectly named in Wine. Should be GpHatchStyle Product: Wine Version: unspecified Hardware: x86-64 OS: Mac OS X Status: UNCONFIRMED Severity: normal Priority: P2 Component: gdiplus Assignee: wine-bugs@winehq.org Reporter: hughbellars@gmail.com
The following code compiles fine on Windows. On Wine, it fails to compile. The fix is to rename "GpHatchStyle" to "HatchStyle"
#include "Windows.h" #include "GdiPlus.h"
using namespace Gdiplus; using namespace DllExports;
int main() { GpHatchStyle hatchStyle;
return 0; }