Aric Stewart <aric(a)codeweavers.com> wrote:
> + char* idx = strrchr(name,'_');
> + if (idx)
> + {
> + if (strcasecmp(idx,"_r")==0 || strcasecmp(idx,"_l")==0)
> + {
> + INT rc = 0;
> + TRACE("found scan=%04x keyc=%u keysym=%04x modified_string=%s\n",
> + scanCode, keyc, (int)keys, debugstr_an(name,idx-name));
> + if (lpBuffer && nSize)
> + {
> + rc = MultiByteToWideChar(CP_UNIXCP, 0, name, idx-name, lpBuffer, nSize);
Using consistent spacing and avoiding not necessary casts would improve
the readability a bit.
--
Dmitry.