Alexandre Goujon ale.goujon@gmail.com writes:
+#define TEST_SETINFO_(m) \
- hres = EditStreamSetInfo(stream, &info, sizeof(AVISTREAMINFO) ); \
- ok( hres == 0, "got 0x%08X, expected 0\n", hres); \
- hres = AVIStreamInfo(stream, &info2, sizeof(AVISTREAMINFO) ); \
- ok( hres == 0, "got 0x%08X, expected 0\n", hres); \
- ok( info2.m == info.m, "EditStreamSetInfo did not update "#m" parameter\n" );
+#define TEST_SETINFO(m) \
- info.m++; \
- TEST_SETINFO_(m); \
- \
- info.m = 0; \
- TEST_SETINFO_(m);
Please avoid that sort of macros. Add a helper function if necessary, or just spell things out explicitly.