On 7 Jun 2018, at 16:11, Bob Wya bob.mt.wya@gmail.com wrote:
Thanks for the valuable feedback! I think I spent quite a bit of time fiddling with this, so I've probably "lost the wood for the trees" a bit... :-)
Just to clarify a style point, for the re-factored patches...
If I still want to split the _SHCreateSymbolicLinks() function into a re-factored implementation that has an iterative wrapper function, is it OK to call them:
_SHCreateSymbolicLink() _SHCreateSymbolicLinks()
?? This would introduce a new "Camel Case" style function name... But would obviously be more consistent...
For new functions you’d avoid CamelCase and use something like create_symbolic_link(). If might be ok to rename existing functions if the patch is small enough. The problem at the moment is that the patch is much too large.
Huw.